Blog.gowifi

Blog.gowifi

logos (other)

Logos

Go Wireless NZ

Wednesday, April 8, 2015

Configure the Sierra Wireless MC7304 for MikroTik

Scenario:
In this blog we will explain how to setup a Mikrotik 3G/4G Router using the RB912UAG-2HPnD and MC7304 Sierra Wireless Card.

Step 1 - Configuring the MC7304:
/system routerboard usb set type=mini-PCIe
/interface ppp-client
set ppp-out1 data-channel=2 disabled=no info-channel=0 port=usb1
/ip firewall nat
add action=masquerade chain=srcnat out-interface=ppp-out1
/ip dns
set allow-remote-requests=yes servers=8.8.8.8

Step 2 - Configure ether1 as the internal LAN:
/ip pool
add name=dhcp_pool1 ranges=192.168.1.2-192.168.1.254
/ip dhcp-server
add address-pool=dhcp_pool1 disabled=no interface=ether1 lease-time=3d name=dhcp1
/ip address
add address=192.168.1.1/24 interface=ether1 network=192.168.1.0
/ip dhcp-server network
add address=192.168.1.0/24 gateway=192.168.1.1

Don't forget to configure your firewall!

2 comments:

  1. Is there any way to separate the info-channel from the data-channel so that I can read the info while the modem is connected? At the moment it's either be connected, or read info from the modem. This is really limiting.

    Is it a restriction of the modem?

    ReplyDelete
    Replies
    1. I have found some documentation that may suggest the info channel is incorrect in this blog. from what i can see it might actually be 0 not 2. This might help?

      Delete