Blog.gowifi

Blog.gowifi

logos (other)

Logos

Go Wireless NZ

Follow by Email

Friday, August 24, 2012

Telecom MF626/636 on a Mikrotik RouterBoard



Scenario:
Most Telecom XT USB Modems initiate as a USB CDROM until the device receives an umount command. This stops RouterOS seeing the device as a Modem. To fix this, you need to program the modem to not run as a CDROM when first powered up.



You need to pass a command to the modem, either as a one off dial string, or through a terminal emulator like hyper-terminal or PuTTY to achieve this.


Connecting to the 3G dongle serial port:



Plug in the USB modem and install the software provided with the device. Navigate to the Device Manager (Control Panel -> System -> Hardware -> Device Manager). Under the Ports section, find the COM port that is connected to the USB modem (ignore the Diagnostics mode). Connect to that COM port through Hyper Terminal.

Terminal Connection Parameters:
Bits per Second: 115200
Data bits: 8
Parity: None
Stop bits: 1
Flow Control: None



Disable CD Autorun Mode:

Once connected to the COM port of the modem enter the following to disable CD Autorun:

AT+ZOPRT=5
AT+ZCDRUN=8


Note:
If you ever wish to re-enable this feature you can use the following command:

AT+ZCDRUN=9


Plug the 3G USB modem into RouterOS and confirm it has been recognised successfully:

[[email protected]] > /port print




Configuring your PPP connection in MikroTik:

RouterOS automatically creates a PPP connection when the usb modem is detected. The MF626 provides 3 channels:

Ch0 = Controller Channel
Ch1 = Information Channel
Ch2 = Data Channel


Configure the PPP Interface Profile:
[[email protected]] > /ppp profile add name=3G-profile change-tcp-mss=yes


Configure the PPP Interface:

[[email protected]] > /interface ppp-client add name=ppp-3g port=usb1 apn=internet.telecom.co.nz add-default-route=yes use-peer-dns=yes profile=3G-profile data-channel=2 info-channel=1 dial-command=ATDT phone=*99# disabled=no

1 comment:

  1. Awesome. Thanks. Up and running saved me a bunch of time with the Autorun shenanigans.

    ReplyDelete